Windows 7 Installation error

Posted by: frankovitchs on 8 September 2017, 2:01 pm EST

  • Posted 8 September 2017, 2:01 pm EST

    Hi,

    I'm trying to install Spread 4 for Windows forms on Windows 7 64 bit and I get an error message 'Installation has ended prematurely because of an error'.  This appears after I click 'Next from the 'Welcome' screen.

    I have tried with the UAC disabled and enabled, running as administrator, and i have run the regsvr32 scripts for vbscript.dll.  

    The problem still persists and I cannot install the tools.  I have read the other post (http://www.clubfarpoint.com/Forums/forums/thread/58479.aspx), and I have contacted support who directed me here in hopes to get some help from the community.

    Does anyone have any other suggestions that might be able to assist me?

     Thanks 

     Stephen 

  • Replied 8 September 2017, 2:01 pm EST

    Stephen,


    The only time I see this issue is when vbscript.dll is not registered correctly. You should not have to turn off the UAC or run the setup with Admistrative Privledges. Make sure you have registered vbscript.dll correctly.



    1. Start Menu -> All Programs -> Accessories -> Right Click on Command Prompt -> Run As Administrator.

    2. Type “cd C:\Windows\SysWOW64?

    3. Type regsvr32 vbscript.dll

    If you don’t do Run as Administrator, the regsvr32 will fail.  Also, be careful to run the command in SysWOW64, not System32!  System32 on a 64-bit system actually contains the 64-bit system libraries.

  • Replied 8 September 2017, 2:01 pm EST

    Hi Scott,

     

    Thanks for the reply, I followed the steps you listed to register the 32 bit .dll.  I then checked to make sure the dll was registered and it is, but when I run the setup I get the same issue.

    Could there be an issue with both versions of the dll being registered?  I will try unregistering the 64 bit dll and see what happens...

     

    Thanks 

  • Replied 8 September 2017, 2:01 pm EST

    Hello,


    The only time I have seen this error in the location you have specified is due to the dll not registered, so I am surprised registering it did not work for you. I did test installing the latest Spread for Windows Forms version 4 setup on Windows 7 64 bit and it ran correctly on my computer. Do you have any other Windows 7 (or other OS) computers to test the install?

  • Replied 8 September 2017, 2:01 pm EST

    Hi Scott,

     I've found the issue with my install.  After some searching it appears that the vbscript.dll file that is shipped with the windows7 evaluation copy has some issues.  If you did an upgrade from vista you most likely kept your vista files, I did a fresh install.

    What I did to solve the issue, was copy out the vista versions of vbscript.dll, put them on my machine and register them.  I was unable to replace my versions of vbscript.dll, so i put them in thier own directory in the windows folder.

     Hope this helps any others that get this issue.

     

    Thanks 

  • Replied 8 September 2017, 2:01 pm EST

    Hello,


    Thank you for passing along the resolution you found. My install of Windows 7 is also a fresh install I have on my VPC, so I do not know what may be different unless we have different builds of the OS.

Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels